You signed in with another tab or window. Reload to refresh your session.You signed out in another tab or window. Reload to refresh your session.You switched accounts on another tab or window. Reload to refresh your session.Dismiss alert
{{ message }}
Repository navigation
Remove support for the standardrb gems from the regular rubocop channels #357
The standard gems added in #351 are currently blocking rubocop updates, just by being referenced in the Gemfile:
rubocop is up to 1.51.0 but standard requires "~> 1.50.2".
rubocop-performance is up to 1.18.0 but standard-performance requires "~> 1.16.0".
I checked with the standard gem maintainers in standardrb/standard-performance#4 and it was made clear that the standard gems can't be updated at the same pace as the rubocop gems they reference, because every rubocop update requires standard to do critical evaluation of the new changes, and can have corresponding config file changes. So, understandably, they can't keep the same release cadence.
However, that means that people who don't use standard will be blocked from using the latest rubocop gems, just because the standard gems they aren't using will block them.
The standard engine doesn't support the case of standard being loaded from rubocop.
The standard engine doesn't support the current version of standard, and hasn't been updated in a couple years.
Given all that, we have a couple options, which we might do both of:
Make separate channel/standard/standard-version branches for rubocop+standard in this codeclimate-rubocop engine, for people who need to load standard from rubocop. Then channel/standard/beta could have the latest version of standard, with the latest rubocop gem versions that standard supports.
@cquinones100, @RubyBrewsday, what do you think? This should make it possible to use standard from rubocop if you want to, but not be blocked by standard if you don't use it.
Activity
BrianHawley commentedon May 24, 2023
@cquinones100, @RubyBrewsday, what do you think? This should make it possible to use standard from rubocop if you want to, but not be blocked by standard if you don't use it.
Update rubocop to 1.55.1 and ruby to 3.2.2
Update rubocop to 1.55.1 and ruby to 3.2.2
Update rubocop to 1.56.1 and ruby to 3.2.2
Update rubocop to 1.56.2 and ruby to 3.2.2
Update rubocop to 1.56.3 and ruby to 3.2.2
Update rubocop to 1.56.3 and ruby to 3.2.2 (#359)